www.homeseer.com    
 

Go Back   HomeSeer Message Board > Lighting & Primary Technology Plug-ins > Lighting & Primary Technology Discussion > Insteon Plug-in (Mark Sandler)

Insteon Plug-in (Mark Sandler) Discussions related to Mark Sandler's 3rd parth plug-in for controlling Insteon devices via Smarthome's PLM interfaces (the 2412 & 2413 series controllers)

Reply
 
Thread Tools Display Modes
  #1  
Old December 19th, 2017, 11:28 PM
leerobinson leerobinson is offline
Seer
 
Join Date: Dec 2016
Location: VT
Posts: 31
Null reference error during startup

Occasionally I see this error in the Startup Log. The same error also occasionally occurs with the Restart Plugin.

12/19/2017 3:03:35 PM ~!~Z-Wave~!~Z-Net Z-Wave: .............................. FINISHED ..............................
12/19/2017 3:03:35 PM ~!~Z-Wave~!~Z-Net Z-Wave: ............................................................ ..........
12/19/2017 3:03:35 PM ~!~Error~!~Initializing plug-in(2): Insteon Instance::Object reference not set to an instance of an object.STACK:Server stack trace: Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessag e(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()
12/19/2017 3:03:35 PM ~!~Plug-In~!~Finished initializing plug-in Insteon
12/19/2017 3:03:36 PM ~!~HSTouch Server~!~Server started on port 10200
12/19/2017 3:03:36 PM ~!~Startup~!~HStouch server started, waiting for clients to connect.
12/19/2017 3:03:39 PM ~!~Z-Wave~!~***************************************************** **************************
12/19/2017 3:03:39 PM ~!~Z-Wave~!~ STARTUP COMPLETE: All configured interfaces were successfully initialized.
Reply With Quote
  #2  
Old December 24th, 2017, 12:00 PM
mnsandler's Avatar
mnsandler mnsandler is offline
Insteon Overlord
 
Join Date: Apr 2005
Location: Virginia
Posts: 10,328
did you get this resolved?
__________________
Mark

HS3 Pro 3.0.0.368
Hardware: Insteon Serial PLM | Vista Alarm 20P with AD2USB | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
Plugins: Insteon 3.0.6.23 (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire | RFXCOM | NetCAM | MyQ | BLRadar | Jon00 Charting
Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory
Reply With Quote
  #3  
Old December 29th, 2017, 07:37 PM
leerobinson leerobinson is offline
Seer
 
Join Date: Dec 2016
Location: VT
Posts: 31
Homeseer says the problem is with the Plugin

When I asked Homeseer about it, they said the problem was with the plugins. What is the next step?

The same error occurs with the Restart Plugin. The author added some additional diagnostic displays and they do not show errors in the Restart Plugin.



The error happened again today. It does not happen every day, only occasionally. I have the server reboot every day at 3:00 PM to reset and clear everything. I experienced reliability issues when I did not have the server reboot periodically.

Here is an excerpt from the startup log:

12/29/2017 3:03:51 PM ~!~Z-Wave~!~Z-Net Z-Wave: ............................................................ ..........
12/29/2017 3:03:51 PM ~!~Plug-In~!~Finished initializing plug-in Restart
12/29/2017 3:03:51 PM ~!~Info~!~Plugin Insteon has connected. IP:127.0.0.1:1207
12/29/2017 3:03:53 PM ~!~Z-Wave~!~***************************************************** **************************
12/29/2017 3:03:53 PM ~!~Z-Wave~!~ STARTUP COMPLETE: All configured interfaces were successfully initialized.
12/29/2017 3:03:53 PM ~!~Z-Wave~!~***************************************************** **************************
12/29/2017 3:03:54 PM ~!~Error~!~Initializing plug-in(2): Insteon Instance::Object reference not set to an instance of an object.STACK:Server stack trace: Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessag e(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()
12/29/2017 3:03:54 PM ~!~Plug-In~!~Finished initializing plug-in Insteon
12/29/2017 3:03:54 PM ~!~HSTouch Server~!~Server started on port 10200
12/29/2017 3:03:54 PM ~!~Startup~!~HStouch server started, waiting for clients to connect.
12/29/2017 3:03:59 PM ~!~Web Server~!~Local IP address (subnet) is: 10.0.0.32 (255.255.255.0)
12/29/2017 3:03:59 PM ~!~Web Server~!~UPNP Discovery started
12/29/2017 3:03:59 PM ~!~Web Server~!~Web Server started on port 80
Reply With Quote
  #4  
Old December 29th, 2017, 07:57 PM
mnsandler's Avatar
mnsandler mnsandler is offline
Insteon Overlord
 
Join Date: Apr 2005
Location: Virginia
Posts: 10,328
can you verify the plugin version you are running, and the version of the insteon.dll file

please post here
Reply With Quote
  #5  
Old December 29th, 2017, 08:06 PM
leerobinson leerobinson is offline
Seer
 
Join Date: Dec 2016
Location: VT
Posts: 31
plugin version 3.0.6.0 Inteon.dll 1.0.6.0 11/28/2016
Reply With Quote
  #6  
Old December 29th, 2017, 08:41 PM
mnsandler's Avatar
mnsandler mnsandler is offline
Insteon Overlord
 
Join Date: Apr 2005
Location: Virginia
Posts: 10,328
can you disable all your other plugins and restart hs a few times and see if you get the error
Reply With Quote
  #7  
Old December 29th, 2017, 08:52 PM
leerobinson leerobinson is offline
Seer
 
Join Date: Dec 2016
Location: VT
Posts: 31
I disabled CM15A, Restart, and ZWAVE plugins, then restarted 3 times, no errors.
Reply With Quote
  #8  
Old December 29th, 2017, 08:54 PM
leerobinson leerobinson is offline
Seer
 
Join Date: Dec 2016
Location: VT
Posts: 31
I could do without the Restart plugin for several days and see if the error occurs again.
Reply With Quote
  #9  
Old December 29th, 2017, 08:57 PM
mnsandler's Avatar
mnsandler mnsandler is offline
Insteon Overlord
 
Join Date: Apr 2005
Location: Virginia
Posts: 10,328
After your test, Also try enabling other plugins one by one to see which one might be causing the problem for the others
Reply With Quote
  #10  
Old December 29th, 2017, 10:15 PM
leerobinson leerobinson is offline
Seer
 
Join Date: Dec 2016
Location: VT
Posts: 31
I disabled the other three plugins then enabled them one-by-one, restarting several times after each was enabled. No errors. Unfortunately, it is an intermittent error. I hate having them in my programs.
Reply With Quote
  #11  
Old December 30th, 2017, 10:16 AM
mnsandler's Avatar
mnsandler mnsandler is offline
Insteon Overlord
 
Join Date: Apr 2005
Location: Virginia
Posts: 10,328
Let me know what you find.
Reply With Quote
Reply

Bookmarks

Tags
error, insteon, null reference, startup, startuplog

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Null reference? Uncle Michael Ecobee (3P) 5 February 18th, 2018 11:40 PM
Null object reference error in Startup Log leerobinson Restart Plug-in 26 January 28th, 2018 04:04 PM
Error trying to include or exclude - object is null mikee123 Z-NET 0 April 15th, 2017 04:52 PM
ERROR Array cannot be null baudi IFTTT (3P) 0 November 4th, 2016 06:50 PM
Buildpage Error Message: Error in LINEStatus: Value cannot be null simonog Jon00's plugins and scripts 5 January 26th, 2008 08:06 PM


All times are GMT -4. The time now is 04:57 AM.


Copyright HomeSeer Technologies, LLC