www.homeseer.com    
 

Go Back   HomeSeer Message Board > Lighting & Primary Technology Plug-ins > Lighting & Primary Technology Discussion > Insteon Plug-in (Mark Sandler)

Insteon Plug-in (Mark Sandler) Discussions related to Mark Sandler's 3rd parth plug-in for controlling Insteon devices via Smarthome's PLM interfaces (the 2412 & 2413 series controllers)

Reply
 
Thread Tools Display Modes
  #1  
Old March 18th, 2018, 12:30 PM
aidesigner aidesigner is offline
Seer
 
Join Date: Mar 2018
Location: Texas
Posts: 14
Keypad and Fanlinc malfunction from HS device view

Setup:
I have a 6 button Keypad that controls a Fanlinc as follows: Fan High(Btn3), Fan Medium(Btn4), Fan low (Btn5), and Fan off (Btn6). The Insteon plugin links in the Keypad are correct and "Sync linked responder devices" is checked. Everything works as expected when operated from the keypad. For example Btn5 turns off other keypad button lights and the fan comes on at low speed.

Problem:
Problems occur if I activate a button like Fan low from the HS device view or voice command. First I see the Fan low (Btn5) light up, but Fan off (Btn6) does not turn off. Also the fan always comes on at high speed (Happens no matter what speed is selected). Judging from your response here you support this functionality. I have 5 fanlinc/keypad pairs in my setup with same issue, which reduces the chance of a typo or communication issue. Perhaps an alternative is to use groups, but that adds a lot of clutter, confusion, and work.

Debug:
Attached is the detailed HS log from both the direct keypad "Fan low" press (works) and the indirect HS view "Fan low" press (broken). The logs seem to indicate the correct actions are being taken in both cases. In the direct keypad case a value of 33 is written to the Fanlic, whereas for the HS btn the new value is not logged (Perhaps it is incorrectly 100). I am using the Insteon 2245-222 for which direct logs are not available.

HS3 Pro Edition 3.0.0.368
Insteon plugin v3.0.6.0
Attached Files
File Type: txt KeypadDirectPress.txt (3.0 KB, 1 views)
File Type: txt KeypadHSViewPress.txt (6.7 KB, 0 views)
Reply With Quote
  #2  
Old March 18th, 2018, 01:33 PM
mnsandler's Avatar
mnsandler mnsandler is offline
Insteon Overlord
 
Join Date: Apr 2005
Location: Virginia
Posts: 10,543
please try the latest beta. i did some work on KPL button syncing which might fix this issue

the beta is available in the Beta section of the Updater
__________________
Mark

HS3 Pro 3.0.0.368
Hardware: Insteon Serial PLM | Vista Alarm 20P with AD2USB | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
Plugins: Insteon 3.0.6.23 (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire | RFXCOM | NetCAM | MyQ | BLRadar | Jon00 Charting
Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory
Reply With Quote
  #3  
Old March 20th, 2018, 08:58 AM
aidesigner aidesigner is offline
Seer
 
Join Date: Mar 2018
Location: Texas
Posts: 14
Works better but fanlinc speed is still stuck high

I have updated to Insteon plugin v3.0.6.30. The keypad buttons now properly act like radio buttons (Only 1 active) - Thanks. However the fanlinc speed is still always high (Value=100), no mater which keypad/fanlinc speed selected. The log line below are for low speed selection and reveal that the HS device button press is setting the fanlinc value=100 (High). Also shown below is a direct button press log entry, which correctly sets the fanlinc value=33. The complete direct and HS log files for the low speed press are attached.

If possible a fix would be highly appreciated. I have a lot of keypad/fanlinc devices and the high fan speed is like a small hurricane.

Also the Insteon beta version brings up a persistent CMD window upon each boot with the following text. If I close the window it will come back when I refresh the Insteon configuration web page.

Persistent windows CMD prompt
Plugin: Insteon Instance: starting...
Connecting to server at 127.0.0.1...
Connected, waiting to be initialized...


HS device low-speed button log entry (Broken):
Insteon Setting value for device 47.68.75:2. Old Value:0, New Value: 100

Direct Keypad low-speed button log entry (Works):
Insteon Setting status and value for device 47.68.75:2. Old status:0 Old Value:0, New Status:4 New Value:33

HS3 Pro Edition 3.0.0.368
Insteon plugin v3.0.6.0.30

Thanks,
aidesigner
Attached Files
File Type: txt KeypadDirectPress2.txt (2.7 KB, 0 views)
File Type: txt KeypadHSViewPress2.txt (5.4 KB, 0 views)
Reply With Quote
  #4  
Old March 20th, 2018, 09:22 AM
mnsandler's Avatar
mnsandler mnsandler is offline
Insteon Overlord
 
Join Date: Apr 2005
Location: Virginia
Posts: 10,543
thanks for the feedback. i'll look into the fan speed issue you pointed out
Reply With Quote
  #5  
Old March 21st, 2018, 09:15 AM
mnsandler's Avatar
mnsandler mnsandler is offline
Insteon Overlord
 
Join Date: Apr 2005
Location: Virginia
Posts: 10,543
I just posted 3.0.6.31 which i think fixes the fanlinc/kpl btn issue you mentioned. please install, test and report back here.
Reply With Quote
  #6  
Old March 21st, 2018, 10:26 AM
aidesigner aidesigner is offline
Seer
 
Join Date: Mar 2018
Location: Texas
Posts: 14
It works

Alright, it works - thanks.

The Insteon plugin still launches the persistent windows CMD window below. Is this just a side effect of using a beta plugin?

Reply With Quote
  #7  
Old March 21st, 2018, 10:34 AM
mnsandler's Avatar
mnsandler mnsandler is offline
Insteon Overlord
 
Join Date: Apr 2005
Location: Virginia
Posts: 10,543
can you check to see if the you have the Developer mode option checked on the manage plugin page
Reply With Quote
  #8  
Old March 21st, 2018, 08:22 PM
aidesigner aidesigner is offline
Seer
 
Join Date: Mar 2018
Location: Texas
Posts: 14
Thanks, the developer mode setting was the issue.
Reply With Quote
  #9  
Old March 22nd, 2018, 07:12 PM
mnsandler's Avatar
mnsandler mnsandler is offline
Insteon Overlord
 
Join Date: Apr 2005
Location: Virginia
Posts: 10,543
i posted 3.0.6.32 in the beta section of the Updater. Please give it a try and confirm the kpl to fanlinc still works as expected.
Reply With Quote
  #10  
Old March 22nd, 2018, 10:32 PM
aidesigner aidesigner is offline
Seer
 
Join Date: Mar 2018
Location: Texas
Posts: 14
Yes version 3.0.6.32 is working fine...
Reply With Quote
  #11  
Old March 23rd, 2018, 08:26 AM
mnsandler's Avatar
mnsandler mnsandler is offline
Insteon Overlord
 
Join Date: Apr 2005
Location: Virginia
Posts: 10,543
Quote:
Originally Posted by aidesigner View Post
Yes version 3.0.6.32 is working fine...
thanks again for reporting back. this same functionality should work between kpl btns and switchlincs, etc.

regarding the fanlinc, if you control the fanlinc for the fanlinc hs devices, they will not update the kpl devices. This is because the fanlinc is a responder only so there are no controller links for the plugin to update the kpl based on changes the fanlinc directly.

you might be able to use the new 'linked' hs2 feature which appears at the bottom of each hs device page, but i will have to defer you to the hs3 forum if you have issue with this feature (its not mine).
Reply With Quote
  #12  
Old March 23rd, 2018, 09:53 AM
aidesigner aidesigner is offline
Seer
 
Join Date: Mar 2018
Location: Texas
Posts: 14
Thanks for the additional information about Fanlinc responder, but it is not a concern. Even if it worked well, controlling a fan with both Keypad and Fanlinc just adds confusion and redundant buttons. I think the Fanlinc should secretly control the fan, and I hide it from both HS device list/Alexa. Just like a Switchlinc controls a light, I conceptually consider the keypad controls the fan. In this regard your plugin is working perfectly
Reply With Quote
  #13  
Old March 23rd, 2018, 10:20 AM
mnsandler's Avatar
mnsandler mnsandler is offline
Insteon Overlord
 
Join Date: Apr 2005
Location: Virginia
Posts: 10,543
thanks again for you help testing and providing feedback.
Reply With Quote
Reply

Bookmarks

Tags
fanlinc, keypad

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!!! Major Malfunction after restart! Stevemeck HomeSeer Software 6 November 16th, 2017 03:43 PM
device showing up in list view but not dashboard view langenet ImperiHome Plug-in (3P) 2 July 1st, 2016 08:15 AM
Fanlinc Insteon Plugin not creating Fan Device airedale HomeSeer General Discussion Area 4 March 22nd, 2016 10:05 PM
Button Malfunction vegascat HSTouch™ 3 April 23rd, 2009 01:53 PM


All times are GMT -4. The time now is 10:45 AM.


Copyright HomeSeer Technologies, LLC