www.homeseer.com    
 

Go Back   HomeSeer Message Board > 3rd Party Plug-Ins/Scripts > Plug-ins by Author > Click Here for List of Author Forums > Blade Plug-Ins > BLSpeech (3P)

BLSpeech (3P) Discussion of BLSpeech plug-in

Reply
 
Thread Tools Display Modes
  #1  
Old September 9th, 2016, 06:43 PM
Jobee Jobee is offline
Seer Deluxe
 
Join Date: Apr 2016
Location: Texas
Posts: 412
Special Tag source= not working

After finally seeing how to work BLSpeech and BLRussound, I setup a test event (below). When the back door closes, the kitchen speakers come on and speak something.

In my setup, my Russound ST2 tuner (XM) is input/source 1. AM/FM is input/source 2 and my speech is input/source 3.

My event uses the special tags to set the priority, set the speaker (and turn it off at the end), set the volume and set the source.

When it runs, the priority, speaker and volume all work. However the source does not. The speaker comes on at the last source used. The BLSpeech directions say to use source=<number of source you want>, in my case 3.

Does anyone have this working? I also tried it with source=speech (which is the name of my source.

------------------- Log ----------------------
Sep-09 18:06:13 TTS Speak: (SPEAKEFAULT):Welcome home. It is currently 6:06 PM
Sep-09 18:06:13 EnvisaLinkAdemco INFO Z02 Back Doors status change: Closed
Sep-09 18:06:13 Event Event Trigger "Announcements Greeting when Back Door Opens/Closes"
-----------------------------------------------

I also have the debug logs for both Russound and Speech.

For grins I removed the |off from the speaker, and tried again. This time it worked, but it did not turn off the speaker.
Attached Images
  
__________________
HS3Pro on Win2012R2
Aeotec, Cooper, Cree, GE/Jasco, Intermatic, LIFX, Fortrezz, OSRAM, RCS, Trane, Zooz
BLBackup, BLGData, BLRussound, BLSpeech, HSTouch, InvisaLink, HSBuddy, IFTTT, NetCAM, PHLocation, Pushover 3P, Random, UltraLighting3, weatherXML, ZigBee, Z-Wave

Last edited by Jobee; September 9th, 2016 at 07:28 PM.
Reply With Quote
  #2  
Old September 9th, 2016, 09:09 PM
sirmeili sirmeili is offline
Super Seer
 
Join Date: Apr 2015
Location: Sebring, FL
Posts: 1,713
Ok, so I'll tell you How I have it set up. I never use the "source" tag (never had to). in the first image below you'll see my settings for BLSpeech for the BLRussound section. Also look at the section below. Once these are set, you don't "need" to use the source tag. As a matter of fact if you set the default speaker or zone, you don't need the speaker tag either.

Also note that "Russound Zones Return to Original State After Speaking" is checked. This is great. So if I'm listening to music in the master bathroom, it will change zones, speak, then return to my original source (and volume). If it is off, it will turn on the zone to the correct source, then turn it off after speaking, making sure to return it to the previous source as well. I never intentionally set any of my zones to "House" (which is the same as your Speech one).

Final note, I never set the default volume. I assume if I don't set it and don't set it in the tag, it will use whatever volume it was already at (or the turn-on volume for that zone). I think I always use the volume tag though.
Attached Images
 
Reply With Quote
  #3  
Old September 9th, 2016, 09:32 PM
Jobee Jobee is offline
Seer Deluxe
 
Join Date: Apr 2016
Location: Texas
Posts: 412
Thanks for the input.

I have the Russound integration boxes checked, so good there.

I have various exit points so I cannot set a default speaker or zone, so I left that in the tags.

I did use the default speech source and removed that special tag.

So my speech text now just has:

{priority=high,speaker=Living Room,volume=50,} Welcome home. It is currently $$time

Now it sets the correct source, completes the speech and returns to the pre-speech source and volume. I like this so if I do have the music on, it does the speech and then returns to what was happening.

Thanks for your help.
Reply With Quote
  #4  
Old September 9th, 2016, 10:09 PM
sirmeili sirmeili is offline
Super Seer
 
Join Date: Apr 2015
Location: Sebring, FL
Posts: 1,713
Quote:
Originally Posted by Jobee View Post
Thanks for the input.

I have the Russound integration boxes checked, so good there.

I have various exit points so I cannot set a default speaker or zone, so I left that in the tags.

I did use the default speech source and removed that special tag.

So my speech text now just has:

{priority=high,speaker=Living Room,volume=50,} Welcome home. It is currently $$time

Now it sets the correct source, completes the speech and returns to the pre-speech source and volume. I like this so if I do have the music on, it does the speech and then returns to what was happening.

Thanks for your help.
No problem! Always glad to help when I can

Sent from my XT1585 using Tapatalk
Reply With Quote
  #5  
Old September 10th, 2016, 10:18 PM
Jobee Jobee is offline
Seer Deluxe
 
Join Date: Apr 2016
Location: Texas
Posts: 412
I have been working with this on and off today. If the Russound is already on and on XM and a speech needs to happen, it does everything correct. It flips to source 3, does the speech at volume 50 and then goes back to XM at the volume it was at. Happy with this part.

But when the Russound is off and a trigger happens, it turns the correct speaker on, sets the speech volume and source and does the speech. This is where the problem then happens. If the Russound was on source 1 but off, when it finishes speaking, it sometimes leaves the source on speech (does not set it back). Also (and the most troubling) is that it seems to turn the power off but the keypad screen stays on (see picture below). This screen part happens every time. The only way to get the keypad to fully shut down is to turn it on again and turn it off.
Attached Images
 
Reply With Quote
  #6  
Old September 11th, 2016, 07:11 AM
S-F's Avatar
S-F S-F is offline
OverSeer
 
Join Date: Jun 2012
Location: Accident MD 21520
Posts: 3,081
This is a bug. Try to capture debug logs for both BLSpeech and BLRussound when it happens and get them to Blade.
__________________
Quote:
Originally Posted by rprade View Post
There is no rhyme or reason to the anarchy a defective Z-Wave device can cause
Reply With Quote
  #7  
Old September 11th, 2016, 03:10 PM
Jobee Jobee is offline
Seer Deluxe
 
Join Date: Apr 2016
Location: Texas
Posts: 412
Got the logs... of course they are large.

Blade - let me know where to send the zip file.

Michael
Reply With Quote
  #8  
Old September 11th, 2016, 03:21 PM
S-F's Avatar
S-F S-F is offline
OverSeer
 
Join Date: Jun 2012
Location: Accident MD 21520
Posts: 3,081
Quote:
Originally Posted by Jobee View Post
Got the logs... of course they are large.

Blade - let me know where to send the zip file.

Michael
Go to his help desk (link in his signature) open a ticket, describe the issue and then attach the logs zipped up.
Reply With Quote
  #9  
Old September 11th, 2016, 06:35 PM
Jobee Jobee is offline
Seer Deluxe
 
Join Date: Apr 2016
Location: Texas
Posts: 412
Ticket 969 created and logs uploaded. I thought you said it was a known bug so I hope I did not confuse things by opening a new ticket.

Michael
Reply With Quote
  #10  
Old September 11th, 2016, 07:57 PM
Blade's Avatar
Blade Blade is online now
OverSeer
 
Join Date: Aug 2003
Location: Ontario Canada
Posts: 7,436
OK I will try and duplicate this here now that I have some zones hooked up to my CAV66
I only have 1 source right now
Bear with me on this - I am still trying to get back to normal after the move to the new house
__________________
Cheers,
Bob
Web site | Help Desk | Feature Requests | Message Board
Reply With Quote
  #11  
Old September 11th, 2016, 09:26 PM
S-F's Avatar
S-F S-F is offline
OverSeer
 
Join Date: Jun 2012
Location: Accident MD 21520
Posts: 3,081
Quote:
Originally Posted by Jobee View Post
Ticket 969 created and logs uploaded. I thought you said it was a known bug so I hope I did not confuse things by opening a new ticket.

Michael
It is a known bug but because it's intermittent I've had a hard time logging it. I'm glad you were able to catch it.
Reply With Quote
  #12  
Old September 13th, 2016, 06:51 AM
Blade's Avatar
Blade Blade is online now
OverSeer
 
Join Date: Aug 2003
Location: Ontario Canada
Posts: 7,436
I will be adding more zones and sources this week so I am aiming for trying to duplicate this on the weekend - I do have to do some work this weekend for my job as well but I am hoping to get time because I really want to nail this down
Reply With Quote
  #13  
Old September 15th, 2016, 05:23 PM
Blade's Avatar
Blade Blade is online now
OverSeer
 
Join Date: Aug 2003
Location: Ontario Canada
Posts: 7,436
I have 7 zones and 3 sources now and I am seeing the same issue with the keypad being left on but plugin thinks it is off
Now I can try and figure this one out
Reply With Quote
  #14  
Old September 15th, 2016, 06:41 PM
S-F's Avatar
S-F S-F is offline
OverSeer
 
Join Date: Jun 2012
Location: Accident MD 21520
Posts: 3,081
Quote:
Originally Posted by Blade View Post
I have 7 zones and 3 sources now and I am seeing the same issue with the keypad being left on but plugin thinks it is off
Now I can try and figure this one out
For the record I have never seen that. I have from time to time seen the source not switch back to where it was originally but the zone always turns off.
Reply With Quote
  #15  
Old September 15th, 2016, 08:54 PM
Blade's Avatar
Blade Blade is online now
OverSeer
 
Join Date: Aug 2003
Location: Ontario Canada
Posts: 7,436
Quote:
Originally Posted by S-F View Post
For the record I have never seen that. I have from time to time seen the source not switch back to where it was originally but the zone always turns off.
Can you attach your hspi_BLSpeech.ini zipped
Reply With Quote
  #16  
Old September 16th, 2016, 12:20 AM
Jobee Jobee is offline
Seer Deluxe
 
Join Date: Apr 2016
Location: Texas
Posts: 412
Quote:
Originally Posted by Blade View Post
Can you attach your hspi_BLSpeech.ini zipped
done
Attached Files
File Type: zip hspi_BLSpeech.zip (926 Bytes, 4 views)
Reply With Quote
  #17  
Old September 16th, 2016, 06:32 AM
Blade's Avatar
Blade Blade is online now
OverSeer
 
Join Date: Aug 2003
Location: Ontario Canada
Posts: 7,436
I have been seeing zones stay on when they should go off. I can duplicate that pretty much every time. I need to play with some delays. I think the calls are being sent to the Russound too fast and it might be missing some. The devices in BLRussound say they are off but the keypad is on.
I think I need to bundle the commands for a speech action and then perform them at once and see what happens. I will play with this and let you know when I have something to try out.
Reply With Quote
  #18  
Old September 16th, 2016, 11:46 AM
Jobee Jobee is offline
Seer Deluxe
 
Join Date: Apr 2016
Location: Texas
Posts: 412
having/fixing the delay would be good. I have two events that happen every morning and even though I put a delay on one of them, they still sometimes bump into each other and one does not work. and on the speak side, I have to delay the start of the speech or it does not catch the first part of the first sentence. So the speaking starts before the unit fully turns on.
Reply With Quote
  #19  
Old September 16th, 2016, 11:52 AM
S-F's Avatar
S-F S-F is offline
OverSeer
 
Join Date: Jun 2012
Location: Accident MD 21520
Posts: 3,081
@Jobee, what Russound system do you have? I have a CAA and don't see these issues even though I make great use of BLSpeech.
Reply With Quote
  #20  
Old September 16th, 2016, 12:16 PM
sirmeili sirmeili is offline
Super Seer
 
Join Date: Apr 2015
Location: Sebring, FL
Posts: 1,713
Quote:
Originally Posted by S-F View Post
@Jobee, what Russound system do you have? I have a CAA and don't see these issues even though I make great use of BLSpeech.
I see them sometimes with my CAA66. I often find my Foyer and Guest bathroom zones on even though they should only ever be off except during "announcements"
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Special tags for more than one source, zone, volume, etc? S-F BLSpeech (3P) 1 June 2nd, 2014 03:17 PM
Play Special Greeting, Hang Up Not Working cfischer HomeSeer Phone 2 September 25th, 2011 03:03 PM
Armed by Special mark_anderson_us BLDSC (3P) 31 August 7th, 2011 11:16 AM
Modem Special Pete HomeSeer Phone 0 December 4th, 2007 10:12 PM
Another McD's special.... glt WAF NetCallerID (3P) 2 August 21st, 2004 09:48 AM


All times are GMT -4. The time now is 05:41 AM.


Copyright HomeSeer Technologies, LLC