www.homeseer.com    
 

Go Back   HomeSeer Message Board > 3rd Party Plug-Ins/Scripts > Plug-ins by Author > Click Here for List of Author Forums > Blade Plug-Ins > BLSpeech (3P)

BLSpeech (3P) Discussion of BLSpeech plug-in

Reply
 
Thread Tools Display Modes
  #1  
Old October 25th, 2016, 04:37 PM
noopara's Avatar
noopara noopara is offline
Seer Master
 
Join Date: May 2002
Location: Gig Harbor, Washington
Posts: 748
HS3 BLSpeech Pre-Speak script not working

Below is my simple script that I have been using for years for HS2 with some minor mods to adapt it to HS3. I am getting this error:

Running script blSpeech_PreSpeak_3.vb :Exception has been thrown by the target of an invocation.->Does entry point Main exist in script? at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Obj ect obj, Object[] parameters, Object[] arguments) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) at A.c17b105f989efe61e5979e67bec1ef734.cffd66cb0782c50126727e3f a75582d7a()

What am I missing here???


Public Sub Main(Parm As Object)


hs.SetVoice("VW Kate 16K")


Select Case hs.DeviceValue("R50") ' amnnounceType


Case 0 'no speakers or intercom (sound is local only)


Case 1 'inside speakers and intercom inside
hs.RunScriptFunc("sendSG_ASCII_3.vb", "Main", "RY02||ON", True, False) 'intercom on
hs.SetDeviceValue("G5", 0) ' inside speakers on


Case 2 'inside and outside speakers and intercom (ALL ON)
hs.RunScriptFunc("sendSG_ASCII_3.vb", "Main", "RY03||ON", True, False) 'intercom door on
hs.SetDeviceValue("G4", 100) ' outside speakers on
hs.SetDeviceValue("G5", 0) ' inside speakers on


End Select

End Sub
Reply With Quote
  #2  
Old October 25th, 2016, 07:05 PM
Blade's Avatar
Blade Blade is offline
OverSeer
 
Join Date: Aug 2003
Location: Ontario Canada
Posts: 7,431
Code:
Public Sub Main(ByVal Parm As Object)

    hs.SetVoice("VW Kate 16K")

    Select Case hs.DeviceValue("R50") ' amnnounceType
        Case 0 'no speakers or intercom (sound is local only)
        Case 1 'inside speakers and intercom inside
            hs.RunScriptFunc("sendSG_ASCII_3.vb", "Main", "RY02||ON", True, False) 'intercom on
            hs.SetDeviceValue("G5", 0) ' inside speakers on
        Case 2 'inside and outside speakers and intercom (ALL ON)
            hs.RunScriptFunc("sendSG_ASCII_3.vb", "Main", "RY03||ON", True, False) 'intercom door on
            hs.SetDeviceValue("G4", 100) ' outside speakers on
            hs.SetDeviceValue("G5", 0) ' inside speakers on
    End Select

End Sub
__________________
Cheers,
Bob
Web site | Help Desk | Feature Requests | Message Board
Reply With Quote
  #3  
Old October 26th, 2016, 02:37 PM
noopara's Avatar
noopara noopara is offline
Seer Master
 
Join Date: May 2002
Location: Gig Harbor, Washington
Posts: 748
I was able to solve it by changing to DeviceValueEx(132) instead of DeviceValue("R50")
It's working fine now.

Public Sub Main(Parm As Object)
hs.SetVoice("VW Kate 16K")
Select Case hs.DeviceValueEx(132) ' announceType
Case 0 'no speakers or intercom (sound is local only)
Case 1 'inside speakers and intercom inside
hs.RunScriptFunc("sendSG_ASCII_3.vb", "Main", "RY02||ON", True, False) 'intercom on
hs.SetDeviceValue("G5", 0) ' inside speakers on
'Case 2 'inside and outside speakers and intercom (ALL ON)
hs.RunScriptFunc("sendSG_ASCII_3.vb", "Main", "RY03||ON", True, False) 'intercom door on
hs.SetDeviceValue("G4", 100) ' outside speakers on
hs.SetDeviceValue("G5", 0) ' inside speakers on
End Select
End Sub
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
JSON Speak request not working matt246 HS3 / HS3PRO Discussion 1 October 22nd, 2016 05:24 AM
Been a month & a half and still Speak command to Tablets not working? mpovolo HomeTroller-SEL 4 May 17th, 2015 09:45 AM
Speak not working on HSPRO & SEL Linux unit mpovolo HS3 / HS3PRO Discussion 3 March 31st, 2015 02:29 PM
Speak not working for wav files. Snelvuur SqueezeBox Plug-In (3P) 5 August 1st, 2010 11:26 AM
Speak Phrase working ? petez69 UltraM1G HSPI 5 May 12th, 2007 09:22 PM


All times are GMT -4. The time now is 09:48 AM.


Copyright HomeSeer Technologies, LLC