www.homeseer.com    
 

Go Back   HomeSeer Message Board > Media Plug-ins > Media Discussion > SqueezeBox Plug-In (3P)

SqueezeBox Plug-In (3P) Discussion area for the SqueezeBox plug-in by PCP.

Reply
 
Thread Tools Display Modes
  #1  
Old December 14th, 2016, 09:21 AM
ArbWare's Avatar
ArbWare ArbWare is offline
Seer Deluxe
 
Join Date: Apr 2006
Location: Columbus, Ohio
Posts: 490
Losing connection to server?

Server on NSA320 NAS
i connect fine...
It sees the library stats (total artists/genres/etc)
It sees the player o.k. (running local on hs3 machine squeezelite)

But it keeps disconnecting.. (then reconnecting,... )

The error in the log is:

Code:
Dec-14 8:10:51 AM	 	SqueezeBox Warning	Communication error upon sockDataArrival Receive: An existing connection was forcibly closed by the remote host
Dec-14 8:10:51 AM	 	SqueezeBox Error	An unexpected error occured in the QueryServer() function/subroutine: [System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags) at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size) --- End of inner exception stack trace --- at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size) at System.IO.StreamReader.ReadBuffer() at System.IO.StreamReader.ReadLine() at HSPI_SqueezeBox.hs_socket_io.ReadString() at HSPI_SqueezeBox.HSPI.QueryServer(String query)]
Things i have tried:
Make sure firewall is off on HS3 machine
Changed CLI port (in plugin and on LMS server) from 9595 to 9095

Rebooted nas several times.. rebooted hS3 machine several times.

HS3 Pro Edition 3.0.0.297 (Windows)
SqueezeBox Plugin 3.1.4.9

LMS Server info
Logitech Media Server Version: 7.7.1 - r33735 @ Mon Nov 28 16:49:58 MST 2011
Hostname: NSA320
Server IP Address: 192.168.1.123
Server HTTP Port Number: 9000
Operating system: Linux - EN - utf8
Platform Architecture: armv5tel-linux
Perl Version: 5.10.0 - armv5tel-linux
Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)
Total Players Recognized: 1

I can music without issue if i go to the 192.168.1.123:9000 screen.

Any ideas of where i should look for issue?

Thanks
__________________
Regards,

Andrew B.
Reply With Quote
  #2  
Old December 15th, 2016, 08:58 AM
pcp pcp is online now
Super Seer
 
Join Date: Jan 2006
Location: MA
Posts: 1,648
It looks like something in your network is dropping or interrupting the connection, like WIFI connection dropping (if used), firewall issues, etc. I understand you already tried to disable a firewall, but ensure all of them are disabled (on NAS and HS3). For example on Windows while I used non Microsoft virus/firewall software, upon Windows updates, I had the MS Firewall turn on. Also check on the NAS and try to use wired connections instead of WIFI (if that is the case).


Sent from my iPad using Tapatalk
Reply With Quote
  #3  
Old December 15th, 2016, 07:59 PM
ArbWare's Avatar
ArbWare ArbWare is offline
Seer Deluxe
 
Join Date: Apr 2006
Location: Columbus, Ohio
Posts: 490
Thanks pcp... I'm looking at the network closer now...
I thought i had it fixed.. because i rebooted the router.. and didn't have an issue for an hour or so...

But it's back..

In looking at the squeezebox log.. i see the following:


Code:
[16-12-15 15:04:41.7456] main::init (354) Starting Logitech Media Server (v7.7.1, r33735, Mon Nov 28 16:49:58 MST 2011) perl 5.010000
[16-12-15 15:04:43.5908] main::changeEffectiveUserAndGroup (967) Warning: Logitech Media Server must not be run as root!  Trying user nobody instead.
[16-12-15 15:04:51.0194] Slim::Utils::Misc::msg (1305) Warning: [15:04:51.0174] DBIx::Class::ResultSet::update_or_create(): Query returned more than one row.  SQL that returns multiple rows is DEPRECATED for ->find and ->single at /usr/local/zy-pkgs/gui/SqueezeCenter/Slim/Schema.pm line 1879
[16-12-15 15:04:56.5598] Plugins::NPRRadio::Metadata::init (21) Register NPR meta provider, default icon= 
[16-12-15 15:08:05.9081] Plugins::HS3::Plugin::duetControllerCheck (2134) HS3: No active SDT clients so checking for duet only configuration.
[16-12-15 15:31:54.8752] Slim::Networking::Async::Socket::UDP::mcast_add (48) Error: While adding multicast membership, UPnP may not work properly: Invalid argument
[16-12-15 15:37:42.7874] Slim::Networking::UPnP::ControlPoint::_gotError (289) Error retrieving device description: Timed out waiting for data
[16-12-15 16:14:42.7284] Slim::Networking::UPnP::ControlPoint::_gotError (289) Error retrieving device description: Timed out waiting for data
[16-12-15 16:51:42.8955] Slim::Networking::UPnP::ControlPoint::_gotError (289) Error retrieving device description: Timed out waiting for data
[16-12-15 18:24:40.9439] Slim::Plugin::CLI::Plugin::cli_socket_accept (239) Warning: Closing connection: too many connections open! (30)
[16-12-15 18:27:49.5189] Slim::Plugin::CLI::Plugin::cli_socket_accept (239) Warning: Closing connection: too many connections open! (30)
[16-12-15 18:33:06.3996] Slim::Networking::UPnP::ControlPoint::_gotError (289) Error retrieving device description: 401 Unauthorized
[16-12-15 18:34:53.0724] Slim::Plugin::CLI::Plugin::cli_socket_accept (239) Warning: Closing connection: too many connections open! (30)
[16-12-15 18:37:58.2836] Slim::Plugin::CLI::Plugin::cli_socket_accept (239) Warning: Closing connection: too many connections open! (30)
[16-12-15 18:41:03.2673] Slim::Plugin::CLI::Plugin::cli_socket_accept (239) Warning: Closing connection: too many connections open! (30)
[16-12-15 18:45:11.4522] Slim::Plugin::CLI::Plugin::cli_socket_accept (239) Warning: Closing connection: too many connections open! (30)
[16-12-15 18:45:11.4587] Slim::Plugin::CLI::Plugin::cli_socket_accept (239) Warning: Closing connection: too many connections open! (30)
[16-12-15 18:48:19.1462] Slim::Plugin::CLI::Plugin::cli_socket_accept (239) Warning: Closing connection: too many connections open! (30)
[16-12-15 18:48:19.1521] Slim::Plugin::CLI::Plugin::cli_socket_accept (239) Warning: Closing connection: too many connections open! (30)
[16-12-15 18:51:27.6488] Slim::Plugin::CLI::Plugin::cli_socket_accept (239) Warning: Closing connection: too many connections open! (30)
[16-12-15 18:51:27.6543] Slim::Plugin::CLI::Plugin::cli_socket_accept (239) Warning: Closing connection: too many connections open! (30)
[16-12-15 18:54:35.6757] Slim::Plugin::CLI::Plugin::cli_socket_accept (239) Warning: Closing connection: too many connections open! (30)
[16-12-15 18:54:35.6838] Slim::Plugin::CLI::Plugin::cli_socket_accept (239) Warning: Closing connection: too many connections open! (30)
It's a bit greek to me... any idea what a SDT client is?

Will keep pluggng away... what's frustrating.. it worked on a previous machine... but not now... but i can't seem to recreate the situation where it worked. .. i'll figure it out eventually...

Any and all ideas of what to look for are welcome.

Thanks

Last edited by ArbWare; December 15th, 2016 at 08:03 PM. Reason: added to log paste
Reply With Quote
  #4  
Old December 17th, 2016, 06:31 PM
pcp pcp is online now
Super Seer
 
Join Date: Jan 2006
Location: MA
Posts: 1,648
Do you have an player / client that has a display? The message "No active SDT clients so checking for duet only configuration" is posted when the plugin is looking for players with screens (for the screensaver) though this does not drop a connection.
Reply With Quote
  #5  
Old December 17th, 2016, 06:33 PM
pcp pcp is online now
Super Seer
 
Join Date: Jan 2006
Location: MA
Posts: 1,648
Could it be that you have too many processes with open connections running on your NAS and hitting the limit of the OS?
Reply With Quote
  #6  
Old December 19th, 2016, 01:38 PM
ArbWare's Avatar
ArbWare ArbWare is offline
Seer Deluxe
 
Join Date: Apr 2006
Location: Columbus, Ohio
Posts: 490
Hmm... good thoughts...

My players are just the Headless Squeezeslave clients (running on Windows PC's)... So that explains the SDT line...

I'll take a look and see if I can figure out the connection count... It could be some other (FTP, WebServer, etc) item that is triggering the drop?

Thanks for the thoughts.. will let you know what I find.
Reply With Quote
  #7  
Old January 29th, 2017, 10:25 AM
ArbWare's Avatar
ArbWare ArbWare is offline
Seer Deluxe
 
Join Date: Apr 2006
Location: Columbus, Ohio
Posts: 490
Losing connection to server?

Update...
it ended up being a network error... I had a camera that had mistakenly been addressed to the same IP address as the LMS server.

Changed the IP address of camera.. and it's all good!



Sent from my iPad using Tapatalk

Last edited by ArbWare; January 29th, 2017 at 01:17 PM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
losing connection fischb22 iTunes DAAP (3P) 2 August 6th, 2015 11:07 AM
Keep losing connection to HUB The Doge Insteon Plug-in (Mark Sandler) 7 July 14th, 2015 04:36 PM
Losing connection to Asterisk Box? mloebl SIP Connector 19 August 31st, 2007 08:35 AM
OT - losing internet connection for only one PC on lan JeffCharger HomeSeer General Discussion Area 3 April 26th, 2006 06:02 PM
Losing My Internet Connection BobH HomeSeer General Discussion Area 1 January 22nd, 2006 11:02 AM


All times are GMT -4. The time now is 09:20 AM.


Copyright HomeSeer Technologies, LLC