www.homeseer.com    
 

Go Back   HomeSeer Message Board > HomeSeer Products & Services > HomeSeer General Discussion Area

HomeSeer General Discussion Area General discussion about HomeSeer that does not fall into any other category or are not specific to 1.x or 2.x versions of HomeSeer.

Reply
 
Thread Tools Display Modes
  #201  
Old October 14th, 2015, 08:50 AM
Valkilane Valkilane is offline
Seer
 
Join Date: Jan 2015
Location: netherlands
Posts: 14
What i've done in the past when things got messed up on the IOS side:

delete the IOS homebridge data (privacy-homekit) but also in de config.json - Bridge section changed the "name", "username" & "port".

Stipus, thanks for all the effort!

Quote:
Originally Posted by askme View Post
I am running into an error in which Homebridge showed up as an accessory in MyTouchHome, but on setup ran into some error. Now it no longer shows up as an accessory no matter the reboot of all parties. There are several references to this issue on the Homebridge git site that reference a bad entry in the Homekit DB that needs to be cleared out. Not sure how to do that.

Has anyone seen the same thing?
Reply With Quote
  #202  
Old October 14th, 2015, 10:19 AM
stipus stipus is offline
OverSeer
 
Join Date: Aug 2003
Location: FRANCE
Posts: 4,510
Quote:
Originally Posted by TomTom View Post
Stipus, if the Homeseer platform is modified by you, I assume it needs to be re-downloaded from github? Or are the modification you make for new devices in the config file.? If the platform needs to be downloaded again, any idea on how to do that on Linux/Pi ? If you use the instruction given for initial install "git clone https://" command it says folder/file already exist. TIA
Sent from my iPhone
I always posted the last platform version to this thread. You could download it from the board, and just replace homeseer.js in the homebridge/platforms directory. New platform versions are always compatible with older configure files. I added many parameters but they are always optional.
__________________
--
stipus
Reply With Quote
  #203  
Old October 14th, 2015, 10:46 AM
Malosa's Avatar
Malosa Malosa is offline
Seer Master
 
Join Date: Mar 2013
Location: Home
Posts: 1,456
Angry

first of all , thanks for your message


but i did that , and added the path variables , but i get a bunch of errors now ,


installed everything like on the tutorial , i dont know what im doing wrong now

PHP Code:
LINK fatal error LNK1181cannot open input file 'C:\OpenSSL-Win64\lib\libeay
32.lib' 
[C:\Users\Home Security System\Desktop\homebridge\node_modules\HAP-Node
JS
\node_modules\ed25519\build\ed25519.vcxproj
PHP Code:
c:\users\home security system\desktop\homebridge\node_modules\mdns\src\mdns.hpp
(32): fatal error C1083Cannot open include file'dns_sd.h'No such file or
directory (..\src\dns_service_browse.cpp) [C:\Users\Home Security System\Deskto
p
\homebridge\node_modules\mdns\build\dns_sd_bindings.vcxproj]
c:\users\home security system\desktop\homebridge\node_modules\mdns\src\mdns.hpp
(32): fatal error C1083Cannot open include file'dns_sd.h'No such file or
directory (..\src\dns_sd.cpp) [C:\Users\Home Security System\Desktop\homebridge
\node_modules\mdns\build\dns_sd_bindings.vcxproj]
  
dns_service_enumerate_domains.cpp
  dns_service_get_addr_info
.cpp
c
:\users\home security system\desktop\homebridge\node_modules\mdns\src\mdns.hpp
(32): fatal error C1083Cannot open include file'dns_sd.h'No such file or
directory (..\src\dns_service_get_addr_info.cpp) [C:\Users\Home Security System
\Desktop\homebridge\node_modules\mdns\build\dns_sd_bindings.vcxproj]
  
dns_service_process_result.cpp
c
:\users\home security system\desktop\homebridge\node_modules\mdns\src\mdns.hpp
(32): fatal error C1083Cannot open include file'dns_sd.h'No such file or
directory (..\src\dns_service_enumerate_domains.cpp) [C:\Users\Home Security Sy
stem
\Desktop\homebridge\node_modules\mdns\build\dns_sd_bindings.vcxproj]
  
dns_service_ref.cpp

npm ERR
Windows_NT 6.1.7601
npm ERR
argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\
node_modules\\npm\\bin\\npm-cli.js" "install"
npm ERRnode v4.2.1
npm ERR
npm  v2.14.7
npm ERR
code ELIFECYCLE

npm ERR
telldus@0.0.9 install: `node-gyp configure build`
npm ERR! Exit status 1
npm ERR
!
npm ERRFailed at the telldus@0.0.9 install script 'node-gyp configure build'.
npm ERRThis is most likely a problem with the telldus package,
npm ERRnot with npm itself.
npm ERRTell the author that this fails on your system:
npm ERR!     node-gyp configure build
npm ERR
You can get their info via:
npm ERR!     npm owner ls telldus
npm ERR
There is likely additional logging output above.

npm ERRPlease include the following file with any support request:
npm ERR!     C:\Users\Home Security System\Desktop\homebridge\npm-debug.log

C
:\Users\Home Security System\Desktop\homebridge
i also did everything with administrator mode and changed permissions , but i get a bunch of red errors (no such directory from files in homebridge folder node_modules)


Quote:
Originally Posted by askme View Post
Check your Environment and PATH variables. It looks like it is getting confused. Also check the privileges you are running with in case that is an issue.

Windows setup has been problematic. If you installed from the Vera Zip file, that was all prebuilt. To get the new version with Homeseer, you will need to rebuild which requires more pre-reqs installed (Python, Git, NPM, Visual Studio, etc).



Good luck
__________________
Pref Plugins -> Jon's Plugins , Pushover
Phlocation, Easy-trigger by spud

New Plugins ->
1. 2Way push notification(pushbullet) new link
------------------------------------------
2. Homekit plugin by Fraggel
------------------------------------------

HS3Pro 3.0.0.312 on windows 7 ultimate X64 on hp quadcore laptop 8 GB. 687 Devices, 480Events

Last edited by Malosa; October 14th, 2015 at 11:04 AM.
Reply With Quote
  #204  
Old October 14th, 2015, 11:02 AM
askme askme is offline
Seer Deluxe
 
Join Date: Apr 2013
Location: DE
Posts: 136
Quote:
Originally Posted by Valkilane View Post
What i've done in the past when things got messed up on the IOS side:

delete the IOS homebridge data (privacy-homekit) but also in de config.json - Bridge section changed the "name", "username" & "port".

Stipus, thanks for all the effort!
That and a reboot did it for me. Thanks.

And obligatory: Stipus, thanks for all of this.
Reply With Quote
  #205  
Old October 14th, 2015, 11:21 AM
askme askme is offline
Seer Deluxe
 
Join Date: Apr 2013
Location: DE
Posts: 136
Still working on this

In the config.json, I have a couple of questions:

Under "bridge", do the name, username, port, or pin matter? Or are they arbitrarily simulating a non-existent HW device? I have found no doc on them and anything seems to work.

Under "platform", is the the IP:Port of homeseer's web Server port? or its JSON Control port. I am having trouble connecting to devices and trying to narrow down the possible issues.

Thanks.
Reply With Quote
  #206  
Old October 14th, 2015, 11:40 AM
askme askme is offline
Seer Deluxe
 
Join Date: Apr 2013
Location: DE
Posts: 136
Quote:
Originally Posted by Malosa View Post
first of all , thanks for your message


but i did that , and added the path variables , but i get a bunch of errors now ,


installed everything like on the tutorial , i dont know what im doing wrong now

PHP Code:
LINK fatal error LNK1181cannot open input file 'C:\OpenSSL-Win64\lib\libeay
32.lib' 
[C:\Users\Home Security System\Desktop\homebridge\node_modules\HAP-Node
JS
\node_modules\ed25519\build\ed25519.vcxproj
PHP Code:
c:\users\home security system\desktop\homebridge\node_modules\mdns\src\mdns.hpp
(32): fatal error C1083Cannot open include file'dns_sd.h'No such file or
directory (..\src\dns_service_browse.cpp) [C:\Users\Home Security System\Deskto
p
\homebridge\node_modules\mdns\build\dns_sd_bindings.vcxproj]
c:\users\home security system\desktop\homebridge\node_modules\mdns\src\mdns.hpp
(32): fatal error C1083Cannot open include file'dns_sd.h'No such file or
directory (..\src\dns_sd.cpp) [C:\Users\Home Security System\Desktop\homebridge
\node_modules\mdns\build\dns_sd_bindings.vcxproj]
  
dns_service_enumerate_domains.cpp
  dns_service_get_addr_info
.cpp
c
:\users\home security system\desktop\homebridge\node_modules\mdns\src\mdns.hpp
(32): fatal error C1083Cannot open include file'dns_sd.h'No such file or
directory (..\src\dns_service_get_addr_info.cpp) [C:\Users\Home Security System
\Desktop\homebridge\node_modules\mdns\build\dns_sd_bindings.vcxproj]
  
dns_service_process_result.cpp
c
:\users\home security system\desktop\homebridge\node_modules\mdns\src\mdns.hpp
(32): fatal error C1083Cannot open include file'dns_sd.h'No such file or
directory (..\src\dns_service_enumerate_domains.cpp) [C:\Users\Home Security Sy
stem
\Desktop\homebridge\node_modules\mdns\build\dns_sd_bindings.vcxproj]
  
dns_service_ref.cpp

npm ERR
Windows_NT 6.1.7601
npm ERR
argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\
node_modules\\npm\\bin\\npm-cli.js" "install"
npm ERRnode v4.2.1
npm ERR
npm  v2.14.7
npm ERR
code ELIFECYCLE

npm ERR
telldus@0.0.9 install: `node-gyp configure build`
npm ERR! Exit status 1
npm ERR
!
npm ERRFailed at the telldus@0.0.9 install script 'node-gyp configure build'.
npm ERRThis is most likely a problem with the telldus package,
npm ERRnot with npm itself.
npm ERRTell the author that this fails on your system:
npm ERR!     node-gyp configure build
npm ERR
You can get their info via:
npm ERR!     npm owner ls telldus
npm ERR
There is likely additional logging output above.

npm ERRPlease include the following file with any support request:
npm ERR!     C:\Users\Home Security System\Desktop\homebridge\npm-debug.log

C
:\Users\Home Security System\Desktop\homebridge
i also did everything with administrator mode and changed permissions , but i get a bunch of red errors (no such directory from files in homebridge folder node_modules)
First of all, let me just clarify that I gave up on Windows shortly after the point you are at, that said, I think you are having problems with dependencies. I had to install a number of additional Visual Basic and Windows SDK's to get past that point. Check your "Reference Assemblies" directory under WIndows.

I saw another poster indicate they needed also needed OpenSSL installed.
Reply With Quote
  #207  
Old October 14th, 2015, 11:53 AM
Malosa's Avatar
Malosa Malosa is offline
Seer Master
 
Join Date: Mar 2013
Location: Home
Posts: 1,456
thanks for the reply :
i know its a problem only with the telldus@0.0.9 install script 'node-gyp configure build'.

i searched another topic of other people and i installed a lower version of node 0.10.x , still no luck

with the all in one package the old one it worked normal



here is the debug log
PHP Code:
0 info it worked if it ends with ok
1 verbose cli 
'C:\\Program Files\\nodejs\\\\node.exe',
1 verbose cli   'C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js',
1 verbose cli   'run',
1 verbose cli   'start' ]
2 info using npm@1.4.28
3 info using node
@v0.10.40
4 verbose node symlink C
:\Program Files\nodejs\\node.exe
5 verbose run
-script 'prestart''start''poststart' ]
6 info prestart homebridge@0.1.1
7 info start homebridge
@0.1.1
8 verbose unsafe
-perm in lifecycle true
9 info homebridge
@0.1.1 Failed to exec start script
10 error homebridge
@0.1.1 start: `DEBUG=* node app.js || true`
10 error Exit status 1
11 error Failed at the homebridge
@0.1.1 start script.
11 error This is most likely a problem with the homebridge package,
11 error not with npm itself.
11 error Tell the author that this fails on your system:
11 error     DEBUG=* node app.js || true
11 error You can get their info via
:
11 error     npm owner ls homebridge
11 error There is likely additional logging output above
.
12 error System Windows_NT 6.1.7601
13 error command 
"C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "run" "start"
14 error cwd C:\Users\Home Security System\Desktop\homebridge
15 error node 
-v v0.10.40
16 error npm 
-v 1.4.28
17 error code ELIFECYCLE
18 verbose 
exit [ 1true 

installed windows 7 sdk , still no luck , i hope someone can help me please




Quote:
Originally Posted by askme View Post
First of all, let me just clarify that I gave up on Windows shortly after the point you are at, that said, I think you are having problems with dependencies. I had to install a number of additional Visual Basic and Windows SDK's to get past that point. Check your "Reference Assemblies" directory under WIndows.

I saw another poster indicate they needed also needed OpenSSL installed.

Last edited by Malosa; October 14th, 2015 at 12:46 PM.
Reply With Quote
  #208  
Old October 14th, 2015, 01:16 PM
askme askme is offline
Seer Deluxe
 
Join Date: Apr 2013
Location: DE
Posts: 136
Quote:
Originally Posted by Malosa View Post
thanks for the reply :
i know its a problem only with the telldus@0.0.9 install script 'node-gyp configure build'.

i searched another topic of other people and i installed a lower version of node 0.10.x , still no luck

with the all in one package the old one it worked normal



here is the debug log
PHP Code:
0 info it worked if it ends with ok
1 verbose cli 
'C:\\Program Files\\nodejs\\\\node.exe',
1 verbose cli   'C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js',
1 verbose cli   'run',
1 verbose cli   'start' ]
2 info using npm@1.4.28
3 info using node
@v0.10.40
4 verbose node symlink C
:\Program Files\nodejs\\node.exe
5 verbose run
-script 'prestart''start''poststart' ]
6 info prestart homebridge@0.1.1
7 info start homebridge
@0.1.1
8 verbose unsafe
-perm in lifecycle true
9 info homebridge
@0.1.1 Failed to exec start script
10 error homebridge
@0.1.1 start: `DEBUG=* node app.js || true`
10 error Exit status 1
11 error Failed at the homebridge
@0.1.1 start script.
11 error This is most likely a problem with the homebridge package,
11 error not with npm itself.
11 error Tell the author that this fails on your system:
11 error     DEBUG=* node app.js || true
11 error You can get their info via
:
11 error     npm owner ls homebridge
11 error There is likely additional logging output above
.
12 error System Windows_NT 6.1.7601
13 error command 
"C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "run" "start"
14 error cwd C:\Users\Home Security System\Desktop\homebridge
15 error node 
-v v0.10.40
16 error npm 
-v 1.4.28
17 error code ELIFECYCLE
18 verbose 
exit [ 1true 

installed windows 7 sdk , still no luck , i hope someone can help me please

While I don't think it will solve you problem, you can dump Teldus (and most other platforms/Accessories you don't use) out of the package.json and node_accessories directory to avoid having to compile them.
Reply With Quote
  #209  
Old October 14th, 2015, 01:34 PM
Malosa's Avatar
Malosa Malosa is offline
Seer Master
 
Join Date: Mar 2013
Location: Home
Posts: 1,456
ok what can i delete from there , i only want homeseer and sonos ..

get an new error
PHP Code:
npm WARN package.json wemo@0.2.1 No repository field

Quote:
Originally Posted by askme View Post
While I don't think it will solve you problem, you can dump Teldus (and most other platforms/Accessories you don't use) out of the package.json and node_accessories directory to avoid having to compile them.
Reply With Quote
  #210  
Old October 14th, 2015, 01:44 PM
askme askme is offline
Seer Deluxe
 
Join Date: Apr 2013
Location: DE
Posts: 136
Post

Quote:
Originally Posted by Malosa View Post
ok what can i delete from there , i only want homeseer and sonos ..

get an new error
PHP Code:
npm WARN package.json wemo@0.2.1 No repository field


The reason I suggest I don't think it will help as the most complex dependencies are in the core modules.

I would bet you can dump safely the following.

"ad2usb": "git+https://github.com/alistairg/node-ad2usb.git#local",
"carwingsjs": "0.0.x",
"chokidar": "^1.0.5",
"color": "0.10.x",
"eibd": "^0.3.1",
"elkington": "kevinohara80/elkington",
"harmonyhubjs-client": "^1.1.4",
"harmonyhubjs-discover": "git+https://github.com/swissmanu/harmonyhubjs-discover.git",
"lifx-api": "^1.0.1",
"lifx": "git+https://github.com/magicmonkey/lifxjs.git",
"node-hue-api": "^1.0.5",
"node-icontrol": "^0.1.4",
"node-milight-promise": "0.0.x",
"tough-cookie": "^2.0.0",
"sonos": "0.8.x",
"telldus": "0.0.9",
"telldus-live": "0.2.x",
"teslams": "1.0.1",
"unofficial-nest-api": "git+https://github.com/hachidorii/unofficial_nodejs_nest.git#d8d48edc952b049ff6320ef99afa7b2f0 4cdee98",
"wemo": "0.2.x",
"wink-js": "0.0.5",
"komponist" : "0.1.0",
"yamaha-nodejs": "0.4.x",
Reply With Quote
  #211  
Old October 14th, 2015, 01:51 PM
Malosa's Avatar
Malosa Malosa is offline
Seer Master
 
Join Date: Mar 2013
Location: Home
Posts: 1,456
jesus this is so crap right now
lets hope stipus can help out

check this log after deleting



PHP Code:
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V110\Microsoft.Cpp.Platform.t
argets
(44,5): error MSB8020The builds tools for v120 (Platform Toolset 'v12
0'
cannot be foundTo build using the v120 build toolseither click the Proj
ect menu 
or right-click the solution, and then select "Update VC++ Projects..."
Install v120 to build using the v120 build tools. [C:\Users\Home Security Sys
tem
\Desktop\homebridge\node_modules\HAP-NodeJS\node_modules\ed25519\build\ed255
19.vcxproj

PHP Code:
C:\Users\Home Security System\Desktop\homebridge\node_modules\HAP-NodeJS\node_mo
dules
\srp\node_modules\bignum>node "C:\Program Files\nodejs\node_modules\npm\bin
\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" 
configure build
(nodechild_processoptions.customFds option is deprecated. Use options.stdio
instead
.
Building the projects in this solution one at a timeTo enable parallel build,
please add the "/m" switch.
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V110\Microsoft.Cpp.Platform.t
argets
(44,5): error MSB8020The builds tools for v120 (Platform Toolset 'v12
0'
cannot be foundTo build using the v120 build toolseither click the Proj
ect menu 
or right-click the solution, and then select "Update VC++ Projects..."
Install v120 to build using the v120 build tools. [C:\Users\Home Security Sys
tem
\Desktop\homebridge\node_modules\HAP-NodeJS\node_modules\srp\node_modules\bi
gnum
\build\bignum.vcxproj]
gyp ERRbuild error
gyp ERR
stack Error: `msbuildfailed with exit code1
gyp ERR
stack     at ChildProcess.onExit (C:\Program Files\nodejs\node_modules\
npm\node_modules\node-gyp\lib\build.js:267:23)
gyp ERRstack     at emitTwo (events.js:87:13)
gyp ERRstack     at ChildProcess.emit (events.js:172:7)
gyp ERRstack     at Process.ChildProcess._handle.onexit (internal/child_proces
s
.js:200:12)
gyp ERRSystem Windows_NT 6.1.7601
gyp ERR
command "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodej
s\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "configure" "bui
ld"
gyp ERRcwd C:\Users\Home Security System\Desktop\homebridge\node_modules\HAP-N
odeJS
\node_modules\srp\node_modules\bignum
gyp ERR
node -v v4.2.1
gyp ERR
node-gyp -v v1.0.1
gyp ERR
not ok

mdns@2.2.10 install C:\Users\Home Security System\Desktop\homebridge\node_modu
les
\HAP-NodeJS\node_modules\mdns
node-gyp rebuild


C
:\Users\Home Security System\Desktop\homebridge\node_modules\HAP-NodeJS\node_mo
dules
\mdns>node "C:\Program Files\nodejs\node_modules\npm\bin\node-gyp-bin\\..\.
.\node_modules\node-gyp\bin\node-gyp.js" 
rebuild
(nodechild_processoptions.customFds option is deprecated. Use options.stdio
instead
.
Building the projects in this solution one at a timeTo enable parallel build,
please add the "/m" switch.
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V110\Microsoft.Cpp.Platform.t
argets
(44,5): error MSB8020The builds tools for v120 (Platform Toolset 'v12
0'
cannot be foundTo build using the v120 build toolseither click the Proj
ect menu 
or right-click the solution, and then select "Update VC++ Projects..."
Install v120 to build using the v120 build tools. [C:\Users\Home Security Sys
tem
\Desktop\homebridge\node_modules\HAP-NodeJS\node_modules\mdns\build\dns_sd_b
indings
.vcxproj]
gyp ERRbuild error
gyp ERR
stack Error: `msbuildfailed with exit code1
gyp ERR
stack     at ChildProcess.onExit (C:\Program Files\nodejs\node_modules\
npm\node_modules\node-gyp\lib\build.js:267:23)
gyp ERRstack     at emitTwo (events.js:87:13)
gyp ERRstack     at ChildProcess.emit (events.js:172:7)
gyp ERRstack     at Process.ChildProcess._handle.onexit (internal/child_proces
s
.js:200:12)
gyp ERRSystem Windows_NT 6.1.7601
gyp ERR
command "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodej
s\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild"
gyp ERRcwd C:\Users\Home Security System\Desktop\homebridge\node_modules\HAP-N
odeJS
\node_modules\mdns
gyp ERR
node -v v4.2.1
gyp ERR
node-gyp -v v1.0.1
gyp ERR
not ok

ed25519@0.0.3 install C:\Users\Home Security System\Desktop\homebridge\node_mo
dules
\HAP-NodeJS\node_modules\ed25519
node-gyp rebuild


C
:\Users\Home Security System\Desktop\homebridge\node_modules\HAP-NodeJS\node_mo
dules
\ed25519>node "C:\Program Files\nodejs\node_modules\npm\bin\node-gyp-bin\\.
.\..\node_modules\node-gyp\bin\node-gyp.js" 
rebuild
(nodechild_processoptions.customFds option is deprecated. Use options.stdio
instead
.
Building the projects in this solution one at a timeTo enable parallel build,
please add the "/m" switch.
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V110\Microsoft.Cpp.Platform.t
argets
(44,5): error MSB8020The builds tools for v120 (Platform Toolset 'v12
0'
cannot be foundTo build using the v120 build toolseither click the Proj
ect menu 
or right-click the solution, and then select "Update VC++ Projects..."
Install v120 to build using the v120 build tools. [C:\Users\Home Security Sys
tem
\Desktop\homebridge\node_modules\HAP-NodeJS\node_modules\ed25519\build\ed255
19.vcxproj
]
gyp ERRbuild error
gyp ERR
stack Error: `msbuildfailed with exit code1
gyp ERR
stack     at ChildProcess.onExit (C:\Program Files\nodejs\node_modules\
npm\node_modules\node-gyp\lib\build.js:267:23)
gyp ERRstack     at emitTwo (events.js:87:13)
gyp ERRstack     at ChildProcess.emit (events.js:172:7)
gyp ERRstack     at Process.ChildProcess._handle.onexit (internal/child_proces
s
.js:200:12)
gyp ERRSystem Windows_NT 6.1.7601
gyp ERR
command "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodej
s\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild"
gyp ERRcwd C:\Users\Home Security System\Desktop\homebridge\node_modules\HAP-N
odeJS
\node_modules\ed25519
gyp ERR
node -v v4.2.1
gyp ERR
node-gyp -v v1.0.1
gyp ERR
not ok

npm ERR
curve25519@1.1.0 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR
!
npm ERRFailed at the curve25519@1.1.0 install script.
npm ERRThis is most likely a problem with the curve25519 package,
npm ERRnot with npm itself.
npm ERRTell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR
You can get their info via:
npm ERR!     npm owner ls curve25519
npm ERR
There is likely additional logging output above.
npm ERRSystem Windows_NT 6.1.7601
npm ERR
command "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodej
s\\node_modules\\npm\\bin\\npm-cli.js" "install"
npm ERRcwd C:\Users\Home Security System\Desktop\homebridge
npm ERR
node -v v4.2.1
npm ERR
npm -v 1.4.28
npm ERR
code ELIFECYCLE
npm ERR
not ok code 0

C
:\Users\Home Security System\Desktop\homebridge

Quote:
Originally Posted by askme View Post
The reason I suggest I don't think it will help as the most complex dependencies are in the core modules.

I would bet you can dump safely the following.

"ad2usb": "git+https://github.com/alistairg/node-ad2usb.git#local",
"carwingsjs": "0.0.x",
"chokidar": "^1.0.5",
"color": "0.10.x",
"eibd": "^0.3.1",
"elkington": "kevinohara80/elkington",
"harmonyhubjs-client": "^1.1.4",
"harmonyhubjs-discover": "git+https://github.com/swissmanu/harmonyhubjs-discover.git",
"lifx-api": "^1.0.1",
"lifx": "git+https://github.com/magicmonkey/lifxjs.git",
"node-hue-api": "^1.0.5",
"node-icontrol": "^0.1.4",
"node-milight-promise": "0.0.x",
"tough-cookie": "^2.0.0",
"sonos": "0.8.x",
"telldus": "0.0.9",
"telldus-live": "0.2.x",
"teslams": "1.0.1",
"unofficial-nest-api": "git+https://github.com/hachidorii/unofficial_nodejs_nest.git#d8d48edc952b049ff6320ef99afa7b2f0 4cdee98",
"wemo": "0.2.x",
"wink-js": "0.0.5",
"komponist" : "0.1.0",
"yamaha-nodejs": "0.4.x",

Last edited by Malosa; October 14th, 2015 at 02:13 PM.
Reply With Quote
  #212  
Old October 14th, 2015, 02:22 PM
askme askme is offline
Seer Deluxe
 
Join Date: Apr 2013
Location: DE
Posts: 136
Those errors are MSBuild erorrs indicating that it cannot find or cannot build key components. They have to do with your toolchain environment. You need to verify that NPM's build routines can find the right compilers and libraries.

Stipus was stymied by the same thing and shifted to another platform. ewilliams however, claims to have solved it on Win32 at least and I think is your best bet.

I gave up, installed VirtualBox (free), Turnkey Linux (free), followed the various Homebridge install guides and was up and running pretty quickly.

askme
Reply With Quote
  #213  
Old October 14th, 2015, 02:42 PM
Malosa's Avatar
Malosa Malosa is offline
Seer Master
 
Join Date: Mar 2013
Location: Home
Posts: 1,456
its to frustrating...

i think i gonna quit this , its not working , its impossible to install this on windows
Reply With Quote
  #214  
Old October 14th, 2015, 04:20 PM
askme askme is offline
Seer Deluxe
 
Join Date: Apr 2013
Location: DE
Posts: 136
Quote:
Originally Posted by Malosa View Post
its to frustrating...

i think i gonna quit this , its not working , its impossible to install this on windows

http://stackoverflow.com/questions/1...annot-be-found
Reply With Quote
  #215  
Old October 14th, 2015, 04:49 PM
ewillems ewillems is offline
Seer
 
Join Date: Mar 2013
Location: Netherlands
Posts: 40
Guys, please be patient, I have a working version on Windows ready to rolling out... I just need some spare time to publish it .


Sent from my iPhone using Tapatalk
Reply With Quote
  #216  
Old October 14th, 2015, 05:21 PM
askme askme is offline
Seer Deluxe
 
Join Date: Apr 2013
Location: DE
Posts: 136
Quote:
Originally Posted by ewillems View Post
Guys, please be patient, I have a working version on Windows ready to rolling out... I just need some spare time to publish it .


Sent from my iPhone using Tapatalk

The real hero (well, and Stipus).
Reply With Quote
  #217  
Old October 14th, 2015, 05:24 PM
stipus stipus is offline
OverSeer
 
Join Date: Aug 2003
Location: FRANCE
Posts: 4,510
The latest HomeSeer platform V0.8 is now available from the homebridge repository.

HomeSeer platform roadmap:

- Add offEventGroup and offEventName to each HomeSeer event, so that switch on <event name> and switch off <event name> can run 2 different HomeSeer events
- Add Hue and Sat support to lightbulbs
- Better Door support
- Add GarageDoor, Window and WindowCovering support
- Add lock support
- Add Security System support

Anything else ?
Reply With Quote
  #218  
Old October 14th, 2015, 05:29 PM
stipus stipus is offline
OverSeer
 
Join Date: Aug 2003
Location: FRANCE
Posts: 4,510
Quote:
Originally Posted by ewillems View Post
Guys, please be patient, I have a working version on Windows ready to rolling out... I just need some spare time to publish it .

Sent from my iPhone using Tapatalk
Do you have an idea about what we missed ?
We all tried to compile under Windows without success...

So far I tried:

install python 2.7.10
install Visual Studio Express 2013
install GIT
install Bonjour SDK for Windows
install open-ssl
install Node.js
install Homebridge
But npm install still fails !
Reply With Quote
  #219  
Old October 14th, 2015, 06:12 PM
askme askme is offline
Seer Deluxe
 
Join Date: Apr 2013
Location: DE
Posts: 136
Quote:
Originally Posted by stipus View Post
Do you have an idea about what we missed ?
We all tried to compile under Windows without success...

So far I tried:

install python 2.7.10
install Visual Studio Express 2013
install GIT
install Bonjour SDK for Windows
install open-ssl
install Node.js
install Homebridge
But npm install still fails !
The only thing I didn't realize until I moved over to Linux was that if you blow away the entire node_modules directory, it forces a re-pull, and re-build over the entire stack. That solved a ton of version/dependency issues for me on Linux, and i wondered if I shouldn't have tried that on Windows.
Reply With Quote
  #220  
Old October 15th, 2015, 02:50 AM
Malosa's Avatar
Malosa Malosa is offline
Seer Master
 
Join Date: Mar 2013
Location: Home
Posts: 1,456
wow thanks man !!!!


Quote:
Originally Posted by ewillems View Post
Guys, please be patient, I have a working version on Windows ready to rolling out... I just need some spare time to publish it .


Sent from my iPhone using Tapatalk
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Siri integration Jakob.Sand HomeSeer General Discussion Area 32 January 6th, 2017 04:11 PM
Homekit and Homeseer jayman13 HomeSeer General Discussion Area 30 July 16th, 2016 10:48 PM
Homekit - Homeseer bridge? kkkk HomeSeer General Discussion Area 2 January 24th, 2015 03:07 AM
Got Siri Working with HomeSeer! mark_anderson_us HS2 / HSPRO 238 August 8th, 2013 02:04 PM
Apple TV integration with Homeseer Steve Q Audio / Video and Infra-red (IR) Discussion 4 March 25th, 2010 03:01 PM


All times are GMT -4. The time now is 01:42 AM.


Copyright HomeSeer Technologies, LLC