www.homeseer.com    
 

Go Back   HomeSeer Message Board > User Interface Plug-ins > User Interface Discussion > ImperiHome Plug-in (3P)

Reply
 
Thread Tools Display Modes
  #1  
Old March 17th, 2017, 05:12 AM
torkil.braseth@gmail.com torkil.braseth@gmail.com is offline
Seer
 
Join Date: Jul 2016
Location: Norway
Posts: 7
Can't connect to ImperiHome remotely from iphone - Solved!

Hi,

I just set up ImperiHome om my HomeTroller Zee S2 (running HS3 ZEE S2 Edition 3.0.0.313) and I use the iphone ImperiHome app to view and control devices in my home.
This works great as long as my iphone is on the same network as the HomeTroller but I can't get the app to connect from remote. I am trying to connect using MyHS. The app says "Error Invalid response from API".

I also installed the ImperiHome app on an android device using the same Local/Remote URL and Login information and both local and remote access is working great.

For External URL I am using https://connected2.homesser.com/issapi and my MyHS username/password as suggested in the plugin User Guide.

Is there something wrong with the iphone app?
Reply With Quote
  #2  
Old March 17th, 2017, 08:16 AM
cheeryfool's Avatar
cheeryfool cheeryfool is offline
Seer Master
 
Join Date: Apr 2008
Location: Jersey Shore
Posts: 1,440
Can't connect to ImperiHome remotely from iphone

Mine isn't working via myhs anymore either. Same API error. Mine setup is Iphone plus HS3 v .312 on Windows 10
__________________
cheeryfool
Reply With Quote
  #3  
Old March 17th, 2017, 08:28 AM
spud's Avatar
spud spud is offline
Moderator
 
Join Date: Jan 2012
Location: Canada
Posts: 4,112
several users have reported this problem on iOS, I don't know yet what's the problem. I will investigate.
For now the workaround is to use the old method, i.e custom http server and open a port on your router.
Reply With Quote
  #4  
Old March 17th, 2017, 09:41 AM
cheeryfool's Avatar
cheeryfool cheeryfool is offline
Seer Master
 
Join Date: Apr 2008
Location: Jersey Shore
Posts: 1,440
Quote:
Originally Posted by spud View Post
several users have reported this problem on iOS, I don't know yet what's the problem. I will investigate.

For now the workaround is to use the old method, i.e custom http server and open a port on your router.


Thanks
Reply With Quote
  #5  
Old March 20th, 2017, 03:21 PM
spud's Avatar
spud spud is offline
Moderator
 
Join Date: Jan 2012
Location: Canada
Posts: 4,112
It turns out it was a problem on the myhs server configuration, Rich fixed it, and I tested it successfully on my iPad.
Please test as well and let me know. Thanks
Reply With Quote
  #6  
Old March 20th, 2017, 04:54 PM
cheeryfool's Avatar
cheeryfool cheeryfool is offline
Seer Master
 
Join Date: Apr 2008
Location: Jersey Shore
Posts: 1,440
Quote:
Originally Posted by spud View Post
It turns out it was a problem on the myhs server configuration, Rich fixed it, and I tested it successfully on my iPad.

Please test as well and let me know. Thanks


Tested and working. Thanks.
Reply With Quote
  #7  
Old March 20th, 2017, 06:27 PM
torkil.braseth@gmail.com torkil.braseth@gmail.com is offline
Seer
 
Join Date: Jul 2016
Location: Norway
Posts: 7
Thumbs up

Quote:
Originally Posted by spud View Post
It turns out it was a problem on the myhs server configuration, Rich fixed it, and I tested it successfully on my iPad.
Please test as well and let me know. Thanks
Yep, works great now
Reply With Quote
  #8  
Old March 20th, 2017, 08:56 PM
Dagwood Dagwood is offline
Seer
 
Join Date: Nov 2016
Location: Ontario
Posts: 6
Quote:
Originally Posted by spud View Post
It turns out it was a problem on the myhs server configuration, Rich fixed it, and I tested it successfully on my iPad.
Please test as well and let me know. Thanks
Not working for me from a remote location.
Reply With Quote
  #9  
Old March 21st, 2017, 05:06 AM
woodyc79 woodyc79 is offline
Seer
 
Join Date: Dec 2016
Location: Austria
Posts: 19
iPhone working, iPad Air 2 not working

Hello!

I have both devices in the same WIFI, they were both o.k. until the last HS3 Update.
After the HS3 Update the Imperihome connection stopped working on the iPad, I exported the configuration from iPhone to iPad but it still does not work....

Maybe this information helps you?

Kind regards,
Christian Holzmann
Reply With Quote
  #10  
Old March 21st, 2017, 08:26 AM
spud's Avatar
spud spud is offline
Moderator
 
Join Date: Jan 2012
Location: Canada
Posts: 4,112
Quote:
Originally Posted by Dagwood
Not working for me from a remote location.
Quote:
Originally Posted by woodyc79 View Post
Hello!

I have both devices in the same WIFI, they were both o.k. until the last HS3 Update.
After the HS3 Update the Imperihome connection stopped working on the iPad, I exported the configuration from iPhone to iPad but it still does not work....

Maybe this information helps you?

Kind regards,
Christian Holzmann
guys if you want some help, please give me as much information as you can:
- version of HS3, plug-in and IH app?
- how is the plug-in configured (ISS Server settings section), and how the app is configured?
- is MyHS enabled in HS3?
- what error do you get in the IH app?
- on the iOS device that doesn't work, from safari, can you access https://connected2.homeseer.com/issapi/system ? and what does it report?

thanks
Reply With Quote
  #11  
Old March 21st, 2017, 08:44 PM
Dagwood Dagwood is offline
Seer
 
Join Date: Nov 2016
Location: Ontario
Posts: 6
Quote:
Originally Posted by spud View Post
guys if you want some help, please give me as much information as you can:
- version of HS3, plug-in and IH app?
- how is the plug-in configured (ISS Server settings section), and how the app is configured?
- is MyHS enabled in HS3?
- what error do you get in the IH app?
- on the iOS device that doesn't work, from safari, can you access https://connected2.homeseer.com/issapi/system ? and what does it report?

thanks
I'm using HS3 3.0.0.313, plug-in 3.0.0.19, IH 1.5.8.
My ISS server settings have custom http server unchecked and my local API base URL is http://192.XXX.X.XXX:80/issapi. On the IH app I use the same local URL, no remote URL, no login and no password.

When I try and connect remotely with my iPhone I don't get an error message, but nothing on my dashboard connects or updates. I get the "status bar" across the top of the screen indicating it's trying to refresh.

Accessing the URL https://connected2.homeseer.com/issa.../192.XXX.X.XXX prompts me for credentials and then reports {"id":"My Computer Name","apiversion":1}.

Hopefully I've just missed something in my setup.

Thanks.
Reply With Quote
  #12  
Old March 21st, 2017, 09:10 PM
spud's Avatar
spud spud is offline
Moderator
 
Join Date: Jan 2012
Location: Canada
Posts: 4,112
Quote:
Originally Posted by Dagwood View Post
On the IH app I use the same local URL, no remote URL, no login and no password.
If you want to access your system from a remote location (i.e outside from your local network), you need to set the remote URL to https://connected2.homeseer.com/issapi and set the login/password to your myhs credentials
Reply With Quote
  #13  
Old March 21st, 2017, 10:05 PM
Dagwood Dagwood is offline
Seer
 
Join Date: Nov 2016
Location: Ontario
Posts: 6
Quote:
Originally Posted by spud View Post
If you want to access your system from a remote location (i.e outside from your local network), you need to set the remote URL to https://connected2.homeseer.com/issapi and set the login/password to your myhs credentials


Thanks for your help. I figured it was something simple I missed.


Sent from my iPhone using Tapatalk
Reply With Quote
  #14  
Old June 14th, 2017, 05:59 PM
soukietron soukietron is offline
Viewer
 
Join Date: Jun 2017
Location: Houston, TX
Posts: 2
iOS Remote Access Help

Hello.

Brand new user and fighting an uphill battle with this HS learning curve. Thank you for creating the plugin. I'm able to use Imperihome locally over wifi, but not remotely. I noticed that in one of the other threads, there's a field in the imperihome plugin config for "External API Base URL" where I presume the "https://connected2.homeseer.com/issapi" goes. That field is not on my config page.

Below is what my settings are currently. I'm by no means a programmer, so I appreciate any simplified language you could use in assisting me.

- version of HS3, plug-in and IH app?
HS3: 3.0.0.318 (Windows)
IH plugin: 3.0.0.20
IH app (iOS): v1.6.1

- how is the plug-in configured (ISS Server settings section), and how the app is configured?
Use custom http server: check
Http server port: 8072
Https enabled: uncheckes
Https server port: 8043
myhs username and password included

- is MyHS enabled in HS3?
yes

- what error do you get in the IH app?
"Error
Invalid response from API"

- on the iOS device that doesn't work, from safari, can you access https://connected2.homeseer.com/issapi/system ? and what does it report?
I input my myHS credentials and then the text reads "404 Bad Request: /issapi/system"

Any help is greatly appreciated. Thanks!
Reply With Quote
  #15  
Old June 15th, 2017, 09:28 AM
spud's Avatar
spud spud is offline
Moderator
 
Join Date: Jan 2012
Location: Canada
Posts: 4,112
Quote:
Originally Posted by soukietron View Post
Hello.

Brand new user and fighting an uphill battle with this HS learning curve. Thank you for creating the plugin. I'm able to use Imperihome locally over wifi, but not remotely. I noticed that in one of the other threads, there's a field in the imperihome plugin config for "External API Base URL" where I presume the "https://connected2.homeseer.com/issapi" goes. That field is not on my config page.

Below is what my settings are currently. I'm by no means a programmer, so I appreciate any simplified language you could use in assisting me.

- version of HS3, plug-in and IH app?
HS3: 3.0.0.318 (Windows)
IH plugin: 3.0.0.20
IH app (iOS): v1.6.1

- how is the plug-in configured (ISS Server settings section), and how the app is configured?
Use custom http server: check
Http server port: 8072
Https enabled: uncheckes
Https server port: 8043
myhs username and password included

- is MyHS enabled in HS3?
yes

- what error do you get in the IH app?
"Error
Invalid response from API"

- on the iOS device that doesn't work, from safari, can you access https://connected2.homeseer.com/issapi/system ? and what does it report?
I input my myHS credentials and then the text reads "404 Bad Request: /issapi/system"

Any help is greatly appreciated. Thanks!
If you want to use myhs to access your system remotely (=easiest solution), you need to uncheck the "Use custom http server"
Reply With Quote
  #16  
Old June 15th, 2017, 10:43 AM
soukietron soukietron is offline
Viewer
 
Join Date: Jun 2017
Location: Houston, TX
Posts: 2
I unchecked the box, changed the local URL to exclude the server port and it now works locally and remotely.

So awesome. Thanks!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't connect to HS remotely with smartphone RAM Web Server and Interface 11 July 29th, 2012 12:05 PM
iPhone won't connect with myhomeseer address- Solved! Mssoll Clients - Apple iPhone/iPod/iPad 5 January 24th, 2012 08:06 AM
How to set up IP and Port to Remotely connect to HS urrutegui HomeSeer General Discussion Area 1 May 19th, 2007 04:30 AM
How can I remotely connect? jvanv8 Web Server and Interface 16 April 26th, 2004 11:30 PM
How can I remotely connect? jvanv8 Web Server and Interface 0 January 1st, 1970 12:00 AM


All times are GMT -4. The time now is 11:40 PM.


Copyright HomeSeer Technologies, LLC