www.homeseer.com    
 

Go Back   HomeSeer Message Board > Analog & Digital IO Device Plug-ins > Analog & Digital IO Discussion > Arduino Plugin (3P)

Arduino Plugin (3P) Discussions related to the Arduion plugin for HS3 by enigmatheatre

Reply
 
Thread Tools Display Modes
  #1  
Old March 12th, 2018, 11:11 PM
dsieg61 dsieg61 is offline
Seer
 
Join Date: Nov 2013
Location: USA
Posts: 38
Unhappy ArduinoAPI & DHT11 Not Updating

Hello,
I am trying to get the Ardunio to read the input of a DHT11 (temp & humidity). There are some forum subjects on it already, so I did the best I could to duplicate them. I will be the first to admit, I am not a programmer. So, I set up everything, the Arduino w/ Ethernet has no problem connecting to HomeSeer, the Keep Alive log outputs scroll continuously by, but I never get any readings back from the DHT11. To me, it appears that the sketch program never falls into the loop to actually read the measurements. I have tried to alter the "if" conditions so that the loops are accessed, but, nothing. I have attached screenshots, log output, the sketch file for reference. At this point, I am not sure if it is some hardware issue, wrong libraries, or what.
I have HS3 running on a Pi w/ Raspian, the 147 version of the Arduino plugin. the signal pin of the DHT11 is an input on A0, and I think the values should be displayed in Input 3 and 4 of the devices. If someone has 5 minutes to take a look and tell me what noob thing I am overlooking, I would appreciate it. Also, what sketch command can I use to write a line to the log? That would help a lot to determine what is going on with the program.
Thanks,
David
Attached Files
File Type: zip Ardunio-dht11.zip (503.7 KB, 4 views)
Reply With Quote
  #2  
Old March 13th, 2018, 11:14 AM
dsieg61 dsieg61 is offline
Seer
 
Join Date: Nov 2013
Location: USA
Posts: 38
Well, according to this post:

https://forums.homeseer.com/showthread.php?t=169811

I appear to be using the wrong pin for an input. I will try the others, but it still seems like I should be seeing additional activity in the log other than the Keep Alive statements.
David
Reply With Quote
  #3  
Old March 13th, 2018, 12:29 PM
enigmatheatre's Avatar
enigmatheatre enigmatheatre is offline
Super Seer
 
Join Date: Oct 2009
Location: Aberdeen Scotland UK
Posts: 1,815
Quote:
Originally Posted by dsieg61 View Post
Well, according to this post:

https://forums.homeseer.com/showthread.php?t=169811

I appear to be using the wrong pin for an input. I will try the others, but it still seems like I should be seeing additional activity in the log other than the Keep Alive statements.
David
David,

At a quick glance, you have the code in place but this is from the plugin manual:

Although not used by most SD card libraries, A0 is connected to the SD slot's write protect (WP) pin and
A1 is connected to the card detect switch. Both are pulled high by 10k resistors on the Ethernet shield.
These pins therefore cannot be used for analog input with the shield unless they are bent back or
clipped off before inserting the shield into the arduino. Additionally, if a user's circuit uses these pins for
digital IO, the pullups may cause problems for existing circuitry

I would change the pin and send the sketch to the board again to see if this helps you.

If that still is not working get back to me as the debus shows the board connected ok.

Greig.
__________________
Zwave = Z-Stick, 3xHSM100™ 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
Scripts =
Various
Reply With Quote
Reply

Bookmarks

Tags
api, ardunio, dht11, plugin

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Temp08 DHT11 aldo Ultra1Wire2 HSPI 2 August 31st, 2017 08:57 AM
NodeMCU and DHT11 API aldo Arduino Plugin (3P) 4 June 21st, 2017 09:24 AM
DHT11 DHT22 Humidity sensors API ecuboss Arduino Plugin (3P) 49 March 23rd, 2016 05:59 PM
HSTouch not updating Current Track's Album Cover Art and Track Title not updating fvhemert SqueezeBox Plug-In (3P) 5 March 13th, 2013 02:39 PM
SG not updating HS mikemeer JDS (Stargate, TimeCommander) 6 October 1st, 2005 01:37 AM


All times are GMT -4. The time now is 10:43 PM.


Copyright HomeSeer Technologies, LLC