www.homeseer.com    
 

Go Back   HomeSeer Message Board > Audio / Video and Infra-red (IR) Plug-ins > Audio / Video and Infra-red (IR) Discussion > AirplaySpeak

AirplaySpeak This plug-in is a Speak Proxy which allows Homeseer to route annoucements to AirPlay capable devices such as an AirPort Express

Reply
 
Thread Tools Display Modes
  #1  
Old April 14th, 2018, 08:40 PM
stevenseh@gmail.com stevenseh@gmail.com is offline
Seer
 
Join Date: Jun 2016
Location: NC
Posts: 45
Phonemes

It looks like the plugin correctly handles the xml tag for volume as in for example "<volume level="50"> Speak this Text </volume>".

It does not work for the pronunciation "pron" phonemes tag as in for example <pron sym="h eh 1 l ow & w er 1 l d "/>

I get error messages like this one:
Error In SpeakDev calling a speak proxy plug-in, exception is Exception from HRESULT: 0x80045042

Anybody knows how to get the phonemes to work?
Reply With Quote
  #2  
Old April 15th, 2018, 06:30 PM
spud's Avatar
spud spud is offline
Moderator
 
Join Date: Jan 2012
Location: Canada
Posts: 5,003
does this tag works with standard Homeseer Speaker client?

you can try to add the use_sapi=True line in the ini as explained at the end of this thread:
https://forums.homeseer.com/showthread.php?t=167535
Reply With Quote
  #3  
Old April 16th, 2018, 04:06 PM
stevenseh@gmail.com stevenseh@gmail.com is offline
Seer
 
Join Date: Jun 2016
Location: NC
Posts: 45
I had that SAPI statement already in the .ini file.
When I use the tag without the plug-in, it does not speak anything, nor does it give an error message.
I get the error message only when the plug-in is active. In neither case does the hs.speak work.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:20 PM.


Copyright HomeSeer Technologies, LLC