www.homeseer.com    
 

Go Back   HomeSeer Message Board > Lighting & Primary Technology Plug-ins > Lighting & Primary Technology Discussion > HomeSeer Insteon Plug-in

HomeSeer Insteon Plug-in Discussions related to HomeSeer's own Insteon Plug-in

Reply
 
Thread Tools Display Modes
  #1  
Old August 28th, 2016, 10:00 PM
dpm416 dpm416 is offline
Seer
 
Join Date: Feb 2003
Posts: 13
ExtDevSupport.vb in Linux

I've been trying to use the ExtDevSupport.vb script to register an EZRAIN device in Linux. HS3 does not seem to run it. It is in the ./scripts directory. There are two mentions of external devices in the log, waiting to initialize external devices and External Device Registration complete, but no devices appear in the device listing. What am I missing?
Reply With Quote
  #2  
Old August 29th, 2016, 06:15 AM
mnsandler's Avatar
mnsandler mnsandler is offline
Insteon Overlord
 
Join Date: Apr 2005
Location: Virginia
Posts: 10,333
you need to check the script to determine if it will create the device otherwise you may need to create it yourself.
__________________
Mark

HS3 Pro 3.0.0.368
Hardware: Insteon Serial PLM | Vista Alarm 20P with AD2USB | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
Plugins: Insteon 3.0.6.23 (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire | RFXCOM | NetCAM | MyQ | BLRadar | Jon00 Charting
Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory
Reply With Quote
  #3  
Old August 29th, 2016, 08:13 AM
dpm416 dpm416 is offline
Seer
 
Join Date: Feb 2003
Posts: 13
Same script.

HS3 says, " You have 12 internal Insteon device(s) registered in the system, 0 external device(s), and 0 group(s)."

I am using a modified version of the Jonathan Ort script that was supplied with HS. The only difference is that I have added support for multiple ezflora devices, the code is the same, just called for each device.

AND the identical code works in HS2 (running under Windows, of course.) It registered the devices and added them to HS. I was unsure if the script was called when running in Linux.

I presume, by your reply, that it should be run?

It may not be running. The same external device log entries are there even if the script is removed. Added this line: hs.writelog("ExtDevSupport.vb","Registering External Devices") , no corresponding line is written to the log.

Thanks.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
UPB PIM linux hunter69 UPB plugin by Spud (3P) 1 July 7th, 2015 04:54 PM
Current Linux build? New beta Z-Wave Linux 216 doesn't load AbMagFAb HS3/PRO Beta Releases 5 April 4th, 2015 11:40 PM
Anyone Tried HS3 Linux on Centos or Scientific Linux? kennesaw10 HS3/PRO Beta Releases 0 February 3rd, 2014 10:43 AM
I/O Link and ExtDevSupport.vb bbuck2002 Lighting & Primary Technology Discussion 2 August 8th, 2009 06:37 PM
Linux PDC gpnash Script & Plug-In Development 0 November 21st, 2003 01:16 PM


All times are GMT -4. The time now is 07:49 PM.


Copyright HomeSeer Technologies, LLC