www.homeseer.com    
 

Go Back   HomeSeer Message Board > Media Plug-ins > Media Discussion > SqueezeBox Plug-In (3P)

SqueezeBox Plug-In (3P) Discussion area for the SqueezeBox plug-in by PCP.

Reply
 
Thread Tools Display Modes
  #1  
Old October 17th, 2017, 06:02 PM
Tfernandezw Tfernandezw is offline
Seer Plus
 
Join Date: Jan 2016
Location: Ct
Posts: 92
After TTS, Music Plays for 1 sec

Hi All,

I have a weird issue happening with TTS and LMS. After its done playing a speech file, I hear a song playing 1 second and then it stop.

For reference here is my way of doing TTS, please try to follow with me.

Client: Picoreplayer
Amp: Big dumb Amp connect to PCP

16 Channel Relay connected to RPi

I have events for every zone, 8, which simply monitor a virtual device and turn on each speaker. I had to do this because there are two speakers per zone and had to wire each speaker independently to the relay board and they were grounding out if I connected them to the same relay.

Separately I have two counters for every zone. Kitchen Speech and Kitchen Status. The reason to have this is so that I can provide a logic to the speech announcements. The counters are either 1 or 0.

For Example:
Kitchen Speech 1 - meaning I want to hear announcements in the kitchen
Kitchen Status- 0, I hit speakers off on HStouch which not only turns the virtual device to off and therefore the two relays, but also sets the counter to 0.

Living Room Speech - 0
Living Room Speakers - 0

So I open my front door, Alarm Panel register door open, event in HS runs that if Front Door status changes an becomes open then speech "Front Door Open"

Now in the squeezebox speech config event I have it run an event BEFORE speech. This event goes through all the counters and if speech status is 1 (I want to hear TTS in this zone) then it turns it on. If 0 it ignores and doesn't turn it on.

Announcement is heard (most of the time) Seperate issue i'd like to investigate

Then Event after speech, All the speaker status counter which is 0 (meaning I want to hear speech, but I want the zone to turn off after speech) goes through and turns off the zones.

However before the relays close there is a snip bit of a song that plays. Never the same song, it's like there is something playing in the background.

Now, nothing was playing in the background. I have tried to set the music volume to 0, I have paused all the music playing. I have also made sure there wasn't anything playing and left speakers on, with nothing playing to make sure. I have restarted my S6Pro, cycled on and off LMS, the PCP everything.

So now I don't know why it plays music or where it's getting it from, I'm assuming Pandora.

But I've run out of troubleshooting steps from my end and need some help!
Reply With Quote
Reply

Bookmarks

Tags
lms, raspberry pi, relays, speech

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HS audio plays on 1 out of 4 HS Touch clients risquare Audio / Video and Infra-red (IR) Discussion 4 December 5th, 2015 11:30 PM
How do I restore speaker after Wav plays? termite SpeakEasy Plug-In 3 January 9th, 2009 10:10 AM
Player resumes if a wav plays CJVann Windows Media Player 6 April 22nd, 2007 06:17 PM
Plays wav files, but no speak Frank S HS2 / HSPRO 4 September 21st, 2005 12:13 PM


All times are GMT -4. The time now is 12:25 PM.


Copyright HomeSeer Technologies, LLC