www.homeseer.com    
 

Go Back   HomeSeer Message Board > 3rd Party Plug-Ins/Scripts > Plug-ins by Author > Click Here for List of Author Forums > HiTec Homes Plug-Ins > VWS

VWS Discussion area for the VWS (Virtual Weather Station) plug-in by Hi-Tec Home

Reply
 
Thread Tools Display Modes
  #1  
Old February 25th, 2013, 07:07 PM
Wavemagic Wavemagic is offline
Seer
 
Join Date: Feb 2013
Location: Massachusetts
Posts: 39
Question Index outside of bounds of the array error for VWS

I am running HSPRO (V2.5.0.79) and have the VWS Plug-In (V2.2.0.32) connected to my VWS weather station.
I am getting lots of "In SetDevSting, hc=1 dc=str=%/hr: Index was outside the bounds of the array" errors. The results in STATUS of Homeseer appear OK. How do I get rid of all the errors. A screen shot is attached.
Attached Images
 
Reply With Quote
  #2  
Old February 25th, 2013, 07:41 PM
Rupp's Avatar
Rupp Rupp is offline
OverSeer
 
Join Date: Jan 2001
Location: Huntsville, Al. USA
Posts: 37,019
Look one post below yours for a post with the same error.
__________________
-Rupp
Reply With Quote
  #3  
Old February 25th, 2013, 09:13 PM
Wavemagic Wavemagic is offline
Seer
 
Join Date: Feb 2013
Location: Massachusetts
Posts: 39
Thanks for pointing that out to me. I guess I should have read the others first. After reading the string in the post below mine, I am not sure a definitive answer was found. Did I miss something?
Reply With Quote
  #4  
Old February 25th, 2013, 09:24 PM
Rupp's Avatar
Rupp Rupp is offline
OverSeer
 
Join Date: Jan 2001
Location: Huntsville, Al. USA
Posts: 37,019
It appears the plugin author doesn't know the fix but the message shouldn't cause an issue other than filling up your log files. This message was added to HS a few versions ago to try and located some memory leak issues.
Reply With Quote
  #5  
Old February 25th, 2013, 09:26 PM
Wavemagic Wavemagic is offline
Seer
 
Join Date: Feb 2013
Location: Massachusetts
Posts: 39
I think you are correct! All appears to work fine, except for my log getting filled up with annoying RED error messages. Should I just leave all alone for now and maybe someone will find an answer soon or trash the plug-in?
Reply With Quote
  #6  
Old February 25th, 2013, 09:33 PM
Rupp's Avatar
Rupp Rupp is offline
OverSeer
 
Join Date: Jan 2001
Location: Huntsville, Al. USA
Posts: 37,019
Quote:
Originally Posted by Wavemagic View Post
I think you are correct! All appears to work fine, except for my log getting filled up with annoying RED error messages. Should I just leave all alone for now and maybe someone will find an answer soon or trash the plug-in?
Yes, let it be and hopefully the plugin author will find the cause to this issue. Again, it's not really the plugin authors fault as the check was recently added to HS and it may take a bit of time to find the issue.
Reply With Quote
  #7  
Old February 25th, 2013, 09:34 PM
Wavemagic Wavemagic is offline
Seer
 
Join Date: Feb 2013
Location: Massachusetts
Posts: 39
Thanks for the great and fast reply. I will wait and be patient. Thanks for all your help.
Reply With Quote
  #8  
Old February 26th, 2013, 01:18 PM
Rupp's Avatar
Rupp Rupp is offline
OverSeer
 
Join Date: Jan 2001
Location: Huntsville, Al. USA
Posts: 37,019
This has been fixed.
http://board.homeseer.com/showthread.php?t=157569
Reply With Quote
  #9  
Old February 26th, 2013, 01:50 PM
lpitman's Avatar
lpitman lpitman is offline
Seer Master
 
Join Date: Jan 2003
Location: Colorado Springs
Posts: 936
Sorry I didn't wait long enough in my testing, the errors are still showing up, guess I'll keep looking.
__________________
-Larry

A member of "The HA Pioneer Group", MyWebSite

WHS 2011 Server - SageTV, HS 2.2.29 with 9TB Shared Hard Disk.

Plugins:
Ocelot, MitsubishiTV, DenonAVR, DirecTV, DVDMovies, HAI-Thermostat, HAI, Hauppauge, lrpSpeak, MediaPlayer, Rain8Net, Sprinklers, UIRT, VWS.

Hardware:
Intel 3.0Ghz CPU with 12Gb. Ram and 2Tb SATA HD. Davis Inst. VantagePro II, AB8SS, Rain8Net, RC80 Thermostat, OmniProII, Ocelot, X10, UPB, HD-200 Extenders.
Reply With Quote
Reply

Bookmarks

Tags
out of bounds

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 05:17 AM.


Copyright HomeSeer Technologies, LLC